WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#31952 closed enhancement (duplicate)

Make DISALLOW_FILE_EDIT true by default

Reported by: brocheafoin Owned by:
Milestone: Priority: normal
Severity: minor Version: 4.2
Component: General Keywords: has-patch
Focuses: administration Cc:
PR Number:

Description

I couldn't find a ticket proposing this, so here it is.

The theme and plugin editor in the Admin do more harm than good. Those who
know how to use them know better than to use them. Those who use them
don't know the consequences. In my consultancy, we get a sizable number of
requests from people who "broke their site" because they wanted to remove
a line of text from the footer, headed straight to Appearance > Editor and
added a couple of fatal PHP errors along the way.

At the risk of losing a lot of business (!), I think it's time to hide the
File Editor by default.

Attachments (1)

31952.patch (619 bytes) - added by brocheafoin 5 years ago.
Disables file editing in admin unless DISALLOW_FILE_EDIT is defined and false

Download all attachments as: .zip

Change History (5)

@brocheafoin
5 years ago

Disables file editing in admin unless DISALLOW_FILE_EDIT is defined and false

#1 @brocheafoin
5 years ago

  • Keywords has-patch added
  • Severity changed from normal to minor

#2 follow-up: @ocean90
5 years ago

Hiding the editor isn't a solution. I would rather inform users about the editor as proposed in #31779.

#3 in reply to: ↑ 2 @brocheafoin
5 years ago

Replying to ocean90:

Hiding the editor isn't a solution. I would rather inform users about the editor as proposed in #31779.

I had not seen this ticket. Thanks for the pointer. Do you want to mark mine as a duplicate? I'll join the discussion over there.

#4 @Otto42
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #31779.

Note: See TracTickets for help on using tickets.