WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#31958 closed defect (bug) (duplicate)

Private pages does not show in Page Attributes and Edit Menu screen

Reported by: totland Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

I want to place a private page as a child to another private page page, but private pages doesn't show in the Page editor screen, under Page Attributes -> Parent.

Likewise, in the Menu editor screen private pages doesn't show in the View All tab. But, I can search for them and they show in the result.

Change History (2)

#1 @boonebgorges
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I would suggest that this is a feature, not a bug.

In the case of Menus, it'd be problematic to allow private pages to be added. What would happen to menu items that appear as subnavigation to a private item, when viewed by a user without permission to view such items?

In the case of page hierarchy, I guess I do see a use case for having private parents. But there are lots of UX and workflow considerations. If A and B are private pages, and B is a parent of A, what happens when B is made public? We would need to be sure that information about that parent doesn't show anywhere in the interface for users without the capability to read the capacity. This would include fairly low-level filtering of things like wp_dropdown_pages().

Given the complexity involved, and the relatively limited situations where such a use would be worthwhile, I'd say that this is plugin territory. Use the 'page_attributes_dropdown_pages_args' to pass a custom 'post_status' argument that includes 'private' as appropriate.

#2 @SergeyBiryukov
4 years ago

  • Component changed from Administration to Posts, Post Types
  • Resolution changed from wontfix to duplicate

Duplicate of #8592.

Note: See TracTickets for help on using tickets.