WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#31991 closed enhancement (duplicate)

Remove Default Themes "Twentythirteen" and "Twentyfourteen" from latest build

Reported by: nitroxis Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

When we download WordPress project, from https://wordpress.org/latest.zip. The zip files include three default themes by default in the wp-content/themes/ folder. Why should those three of three themes is required and pushed with every downlaod? Only default theme, latest one i.e. "Twentyfifteen" must be included.

This will make download a bit smaller and faster to upload the whole codebase while exchanging between servers.

Change History (1)

#1 @ocean90
7 years ago

  • Focuses accessibility performance removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hello nitroxis, thanks for this suggestion. The download size for a full package shouldn't really matter, since you're doing it only once (per site).

We already had a similiar discussion in #27084. All the default themes are unique/different/interesting/specific and gives new users a nice set.

So I'm closing this one as a duplicate of #27084. You should also take a look at #31948 if you don't need the wp-content directory.

Note: See TracTickets for help on using tickets.