WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#31993 closed defect (bug) (duplicate)

TinyMCE Visual Mode not working

Reported by: Lokimo Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

After updating to 4.2-RC1-32138 i can no longer use the Visual Mode of tinyMCE Editor (with firefox 37 and Chrome 41)

When i pase in Text in the Visual mode and switch to Text mode the Text dissapears.

Also when i save it directly no content is saved. I get an error

TypeError: a.ownerDocument.defaultView.getComputedStyle(...) is nul .../wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=4109-20150406Line 5

Change History (6)

#1 @SergeyBiryukov
5 years ago

  • Version set to trunk

#2 @azaozz
5 years ago

  • Keywords reporter-feedback added

Cannot reproduce. The weird thing is: ownerDocument.defaultView is used only in one place in TinyMCE: in the DomQuery.css() (similar to jQuery's css()) https://github.com/tinymce/tinymce/blob/master/js/tinymce/classes/dom/DomQuery.js#L526

However the code there is wrapped in a try{} catch(){}, not sure how it triggers that error. And since this is in the compressed wp-tinymce.js.gz file, don't think it can be "corrupted file" either...

@Lokimo can you try adding SCRIPT_DEBUG to wp-confing.php and see if that fixes it or at least the error changes: https://codex.wordpress.org/Debugging_in_WordPress

#3 @m_i_n
5 years ago

I think this issue might me related: #31901.

Last edited 5 years ago by SergeyBiryukov (previous) (diff)

#4 @Lokimo
5 years ago

@azaozz Okay @m_i_n was right, #31901 is the same issue. This could be closed. Thanks a lot.

Last edited 5 years ago by Lokimo (previous) (diff)

#5 @Lokimo
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #31901.

#6 @SergeyBiryukov
5 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.