WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 5 months ago

#32041 new defect (bug)

Bulk updating selected Plugins with and without updates fails

Reported by: gmariani405 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Plugins Keywords:
Focuses: ui, administration Cc:
PR Number:

Description

In WordPress 4.1.1 (and possibly some earlier releases of 4) there is a bug in the following scenario.

Your site has n+ plugins that need updated. You navigate to the general 'installed Plugins' page. You select ALL plugins (including those without updates) and go to Bulk Actions and select 'update'. In prior versions WordPress would only update the plugins in the selected list with updates. Currently it takes you to the updating screen and says it's finished without updating any plugins or listing any plugin updates in the updating screen.

Attachments (4)

Screenshot 2015-05-22 11.12.10.png (105.3 KB) - added by gmariani405 4 years ago.
Plugin list to update
Screenshot 2015-05-22 11.12.16.png (40.3 KB) - added by gmariani405 4 years ago.
Update failed
archive.har (88.1 KB) - added by gmariani405 4 years ago.
Har file
archive.harp (88.1 KB) - added by gmariani405 4 years ago.
Harp file

Download all attachments as: .zip

Change History (8)

This ticket was mentioned in Slack in #core by jorbin. View the logs.


4 years ago

#2 @samuelsidler
4 years ago

@gmariani405: Can you explain your steps to reproduce a bit further and test with 4.2.2? It would help to know more about your setup as well.

I wasn't able to reproduce this issue. To test, I did the following with 4.2.2:

  1. Went to /wp-admin/plugins.php
  2. Selected the checkbox at the top of the list view, which ultimately selected all plugins.
  3. Selected "Update" from the "Bulk Actions" drop down menu and pressed "Apply"

After completing step 3, I remained on plugins.php, but the page was refreshed and showed each of my plugins updating. At the bottom of the page is the final statement "All updates have been completed."

#3 @gmariani405
4 years ago

I have to say I am having trouble replicating this issue as well. I've tested on 4.1.1, 5.1.5, and 4.2.2 with all the same result of it listing all the plugins. I have seen this issue first hand 2-3 times so I know it exists ATLEAST 4.1.1 or prior. If I run into it again I'll try and document it well as I can.

But as I mentioned originally, when it works it lists all the plugins that were selected and that they were updated. When it fails, it shows the exact same page without any plugins listed. I can only imagine that maybe it had trouble contacting the server and timed out? If that is the case, it may only happen occasionally, making it more of a pain to narrow down.

#4 @gmariani405
4 years ago

I managed to get this error to reproduce for me today. I was using a site on v4.1.5, selected all the plugins and set to bulk update. No errors occurred in the browser, but the plugins didn't update. Attached are two screenshots and the .har/.harp files.

@gmariani405
4 years ago

Plugin list to update

@gmariani405
4 years ago

Update failed

@gmariani405
4 years ago

Har file

@gmariani405
4 years ago

Harp file

Note: See TracTickets for help on using tickets.