WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32050 closed feature request (duplicate)

Better placement / management of language files

Reported by: Avantart Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: I18N Keywords:
Focuses: Cc:

Description

It is a pain in the ass when language files are overwritten.

The plugin update process should NOT overwrite the languagefiles of the core or any themes.

It is not reasonable to create child themes and generate own textdomains, keeping the language files within the childtheme folder, editing the functions.php of a theme just to keep the language files safe!

Change History (9)

#1 follow-up: @SergeyBiryukov
5 years ago

  • Component changed from Text Changes to I18N

It's possible to disable asynchronous translation updates via async_update_translation filter.

Related/duplicate: #30915, see also #28571.

#2 in reply to: ↑ 1 ; follow-up: @Avantart
5 years ago

Replying to SergeyBiryukov:

It's possible to disable asynchronous translation updates via async_update_translation filter.


A lot is possible. But not for "Plain admins" etc.

Why use difficult options / modifications to stop a unwanted behaviour?
Why not stop the behaviour?
Maybe in the options / general settings?

Sorry, do you think it is a good idea to edit core files?

And this statement: " I don't see how a translation update can easily render a site useless."

this is arrogant. Have a look at the german translation:
"reply to..." or "add comment" is translated to "Hinterlasse eine Antwort".
This is a stupid text which no german would use.
Whenever I edit this, it is overwritten the next time by any update.

Can you imagine the trouble I have with clients when they ask me to have a special text at their site and that is overwritten all the time?
Will they pay me for this unnecessary edits which are a pain in the ass??? No, they would not. They would blame me to choose such a stupid system!

I am angry and annoyed. Please look at this problem from the user-side, from the admin side!

#3 @markoheijnen
5 years ago

I understand why you are angry and annoyed. In this case I do believe the solution of Sergey is one way to go.
WordPress will always do automatic updates of the text and that is fine. From the user-side this is wanted behavior. They want the text to be accurate and be updated when they upgrade to the latest WordPress version.

From a developer side it's not always wanted but I would say that the developer should know that http://translate.wordpress.org exists and how they can submit improvements. And this is exactly what you should try to do first. Otherwise you should google around to find solutions. This was the first hit I found: http://stackoverflow.com/questions/18826977/override-a-wordpress-plugin-translation-file-on-load

#4 @johnbillion
5 years ago

@Avantart It does nobody any good to call things stupid or go off on a rant. Please calm down a little.

There are several options available to you as above. Bear in mind that translations for core do change as improvements are made, so it makes sense that they would be overwritten during an update. Editing a core translation file is the same as editing a core PHP file; you should expect that it will get overwritten during an update.

The reason translations get updated during a plugin or theme update (and not just during a core update) is so that translations can be updated with a much greater frequency than they would be if they were only ever updated when core itself was updated. This helps us deliver accurate translations much more quickly.

As Marko has pointed out, if you think the German translation isn't suitable then we would really love for you to contribute your improved translation to the official version on translate.wordpress.org. That way, your improvements will benefit everyone who uses the German translation on their site, and not just your client.

If your client's translations aren't appropriate for WordPress core, then a much better way to override the translation is via the method linked to by Marko.

#5 follow-ups: @Avantart
5 years ago

there is a problem with the language files: they are in "You" form
we germans (and many other cultivated people / languages) have to forms to address somebody:

"You / du / tu" (personal)
"You / Sie / Vous" (polite)

you see the problem? The official language files are in personal form, clients, business clients, grown up clients do want to use the polite form
but this is overwritten with EVERY plugin update (let it be a minor plugin for minor functionality)!

So you have to upload / upload / upload permanently the language files (in my case more than 40 installations with a big bunch of different plugins)

should I forward my clients' emails to you that the see the effect of this well-thought decision?

it is a pain in the ass and that is why I am so annoyed after around 10 years that I am using WP.

#7 in reply to: ↑ 2 @ocean90
5 years ago

Replying to Avantart:

this is arrogant. Have a look at the german translation:
"reply to..." or "add comment" is translated to "Hinterlasse eine Antwort".
This is a stupid text which no german would use.
Whenever I edit this, it is overwritten the next time by any update.

That's interesting to hear as a validator for the German translation. I'm happy to guide you through contributing to our translation, please read also https://de.wordpress.org/mitwirken/.


If you want to use your own translations then there are plenty of ways to do this. A lot of discussion had happend on #28571, please read it carefully.

#8 in reply to: ↑ 5 @zodiac1978
5 years ago

Replying to Avantart:

you see the problem? The official language files are in personal form, clients, business clients, grown up clients do want to use the polite form
but this is overwritten with EVERY plugin update (let it be a minor plugin for minor functionality)!

This problem has nothing to do with contribution to our translations. It is a problem with default/formal translation and automatic translation updates, mentioned here: #28303

Close as duplicate?

#9 @johnbillion
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is suitably duplicate of #28303.

Note: See TracTickets for help on using tickets.