WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32082 closed defect (bug) (duplicate)

Not accounting for Params in src in wp_video_shortcode

Reported by: cartpauj Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.2
Component: Shortcodes Keywords:
Focuses: Cc:
PR Number:

Description

Trying to pass a src with URI params fails the ext matching here: https://core.trac.wordpress.org/browser/tags/4.1.2/src/wp-includes/media.php#L1761

The issue is due to the regex in wp_check_filetype here: https://core.trac.wordpress.org/browser/tags/4.1.2/src/wp-includes/functions.php#L2052

It needs to be changed to something like:

$ext_preg = '!\.(' . $ext_preg . ‘)(\?.*)?$!i';

Example src URL that fails:
https://wordup.s3.amazonaws.com/99-right-curve-sequence.mp4?AWSAccessKeyId=KEY&Expires=1429813612&Signature=SIG

Attachments (1)

32082.patch (1.3 KB) - added by ocean90 3 years ago.

Download all attachments as: .zip

Change History (2)

#1 @johnbillion
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #30377.

@ocean90
3 years ago

Note: See TracTickets for help on using tickets.