WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#32100 closed defect (bug) (duplicate)

Adding links in the editor creates a serious regression for accessibility

Reported by: piano08man Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Editor Keywords:
Focuses: accessibility Cc:
PR Number:

Description

In the latest production version of WordPress (4.2), the developers removed the link title box in the editor and replaced it with a link text box. This is a serious regression in accessibility support. We can no longer add alt text to a link for users who need more accessibility.

Expected function:

Click here to go somewhere. The link title box allowed us to describe the link with the alt text.

Current function:

Click here to go somewhere. The link text box doesn't allow us to describe anything and just repeats the original text.

Current workaround:

Manually add the alt text via HTML via the text editor.

Why this should change:

No one will ever do that. That will make WordPress links less accessible. This should be reverted ASAP.

Change History (2)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is a serious regression in accessibility support.

Title attributes actually have no useful purpose for accessibility, see #24766.

Regardless, this is a duplicate of #32095, please read the comment by Drew there for an explanation.

#2 @piano08man
5 years ago

Interesting. Good to know I was completely wrong. :)

Note: See TracTickets for help on using tickets.