WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#32121 closed defect (bug) (duplicate)

Failing to create temp

Reported by: mfcorral Owned by:
Milestone: Priority: normal
Severity: major Version: 4.2
Component: Filesystem API Keywords:
Focuses: administration Cc:

Description

The function wp_tempnam fails when the argument $filename constains a long query string.
There is a simply workaround by adding the following two lines to file.php after the line number 154:

153    // Use the basename of the given file without the extension as the name for the temporary directory
154    $temp_filename = basename( $filename );
155    $temp_filename = parse_url($temp_filename);
156    $temp_filename = $temp_filename["path"];

Regards,
Miguel.

Change History (2)

#1 @mfcorral
6 years ago

  • Severity changed from normal to major

The problem is when a plug-in/theme has a large query string in the download URL (like enfold theme has), you can't update the plug-in/theme.

#2 @dd32
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This was fixed indirectly through #31811

Note: See TracTickets for help on using tickets.