Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#32124 closed enhancement (duplicate)

Add "title" attribute support back to TinyMCE

Reported by: dmchale's profile dmchale Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Editor Keywords:
Focuses: Cc:

Description (last modified by ocean90)

In #28206 the OP had simply suggested adding a new field for the link text, and instead we ended up removing the ability for authors to touch the title attribute entirely. See:

http://www.binarytemplar.com/wp-content/uploads/2015/04/missingTitleField.gif

For example, I have a link that I made in a pre-4.2 post with this code for a link...

<a title="WordPress 4.1 - Dinah" href="https://wordpress.org/news/2014/12/dinah/" target="_blank">View the 4.1 release notes here</a>

In the old editor, I had a field for the URL and a field for the title attribute. The text between the <a> tags took care of itself. And while I definitely support the ADDITION of the "Link Text" field in 4.2, I don't see why the title attribute support was removed.

My old content still has all of the old values that I had entered when I wrote my posts before 4.2, but the only way to edit them now is manually via the Text view. I doubt I'm the only author who utilized the title attribute, and would love to see the editor support come back for this value without forcing me to edit my links in the Text view if I want to add this content.

Change History (2)

#1 @ocean90
9 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32095.

#2 @GaryJ
9 years ago

Accessibility-wise, you'll be doing a dis-service to some of your readers as they can't access the content in the title attribute. If the name of the WP release is important, then include it in the anchor text or in plain text nearby.

FWIW, HTML 5.1 draft spec currently discourages the use of the title attribute.

Note: See TracTickets for help on using tickets.