WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#32140 closed defect (bug) (duplicate)

Emoji conversion

Reported by: XgoikenX Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Formatting Keywords:
Focuses: Cc:

Description

Since 4.2. the following is included in ~/wp-includes/default-filters.php

add_filter( 'the_content_feed',   'wp_staticize_emoji'            );
add_filter( 'comment_text_rss',   'wp_staticize_emoji'            );
add_filter( 'wp_mail', 'wp_staticize_emoji_for_email' );
add_action( 'wp_head',             'print_emoji_detection_script',     7    );
add_action( 'wp_print_styles',     'print_emoji_styles'                     );
add_action( 'admin_print_scripts',        'print_emoji_detection_script'                   );
add_action( 'admin_print_styles',         'print_emoji_styles'                             );

The purpose of those invocations appears to be to include js & css code that replaces emoji with images. As the user’s explicit input is overwrittten, I feel this would require an opt-in or at the very least it should be be much more easily disabled. E.g. by unchecking 'convert emoticons like :-) and :-P to graphics on display'.

(ATM users have to add a remove_filter to the childtheme’s functions.php for each filter).

Change History (1)

#1 @SergeyBiryukov
4 years ago

  • Component changed from General to Formatting
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32102.

Note: See TracTickets for help on using tickets.