WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

Last modified 5 years ago

#3215 closed defect (bug) (fixed)

Login & Update functions everything is broken

Reported by: Xmion Owned by: markjaquith
Milestone: 2.0.6 Priority: highest omg bbq
Severity: blocker Version: 2.0.5
Component: General Keywords: Blank page 302 maint-candidate
Focuses: Cc:

Description

Most have been from 4340 or earlier login and all the the updates function inside admin area is broken or stop redirect you.

Just a blank page after you type login/password you aint going nowhere in firefox, explorer you get (The page cannot be displayed) but if you manual write wp-admin/ after you get inside the admin area ... then if you try to make a change and click on a update function etc.. it's the same behavior stuck in a blank page..

Then i installed the 2.0.4 just to check but that worked nice as hell. thats luvv :D

Then i run the latest SVN on my local win comp and everything works fine GAASH :/!

Change History (25)

comment:1 @foolswisdom9 years ago

Sorry, I do not understand. You say that if you run latest SVN you do not have a problem. Why this ticket then?

comment:2 @Xmion9 years ago

If i run the latest SVN on my host or other host it's broken. but on my xampp for windows it works really fine.. and i have been trying to find the problem with no luck

comment:3 @tedfox9 years ago

Probably a problem caused by 4339 and fixed in 4354

comment:4 @Xmion9 years ago

  • Keywords Blank page added
  • Severity changed from normal to critical

OK i have been on every singel page now in the LATEST SVN.. on 3 servers

Every page is broken when you try to post or make a page, change team, activate plugin, make a user, change password etc etc......

And the only thing that works is the update on permalinks.

I have one site my friend has been giving away so i can use it as testing for us all till they gonna have it i guess.

Server Information:
MySQL 4.0.24_Debian-10sarge2-log running on localhost
http://www.teamharmoni.com/phpinfo.php

http://www.teamharmoni.com/wp-login.php
Login: admin
Password testing

If you get a blank page! just type:
http://www.teamharmoni.com/wp-admin/

Hope somebody have something to say about this or what the problem is :/

Following is my errors in 2 browsers:

Firefox
Found

The document has moved here.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request. 

Explorer

The page cannot be displayed 
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.


comment:5 @Xmion9 years ago

I have been trying in hours now to locate the problem with no luck :/ but i giving up hehe :) need to hit the bed. There has to be something broken with the ajax it's all i thinking of, but i don't really know can't think clear anyway so. I installed both 2.0.4 and svn following directories and played.

Login: admin/Password: testing

http://www.teamharmoni.com/svn/

http://www.teamharmoni.com/wp/

comment:6 @Xmion9 years ago

The problem is in pluggable.php

// Cookie safe redirect.  Works around IIS Set-Cookie bug.
// http://support.microsoft.com/kb/q176113/
if ( !function_exists('wp_redirect') ) :
function wp_redirect($location, $status = 302) {
	global $is_IIS;

	$location = preg_replace('|[^a-z0-9-~+_.?#=&;,/:%]|i', '', $location);
	$location = wp_kses_no_null($location);

	$strip = array('%0d', '%0a');
	$location = str_replace($strip, '', $location);

	if ( $is_IIS ) {
		header("Refresh: 0;url=$location");
	} else {
		status_header($status); // This causes problems on IIS
		header("Location: $location");
	}
}

comment:7 @markjaquith9 years ago

To be clear: the status_header(302) line is causing problems?

comment:8 @Xmion9 years ago

  • Cc markjaquith added
  • Owner changed from anonymous to markjaquith

Yes! the status 302 is causing problem. i removed it and every thing works fine with out

$status = 302

comment:9 @ev3rywh3re9 years ago

  • Keywords 302 added

I don't know if I should split this off as a separate report, but my results may be related. My web site here is working fine except for login and dashboard functions. Same results with a cryptic error and 500 error (I think that's because there is no error page for 302 error). Initially going to /wp-admin will produce an unroutable 302 error.

  1. Go to login.php and authenticate. Get unroutable 302 error.
  1. Manually go to /wp-admin and things "kinda" work.

This is actually a yahoo hosted project, so don't laugh. I know there are limitations, and this could also be related the PHP Fast CGI used by yahoo. I thought I would dig a little further, so here is a wget header output when I initally try to go to /wp-admin:

HTTP request sent, awaiting response... 
  HTTP/1.1 302
  Date: Fri, 20 Oct 2006 03:08:43 GMT
  P3P: policyref="http://p3p.yahoo.com/w3c/p3p.xml", CP="CAO DSP COR CUR ADM DEV TAI PSA PSD IVAi IVDi CONi TELo OTPi OUR DELi SAMi OTRi UNRi PUBi IND PHY ONL UNI PUR FIN COM NAV INT DEM CNT STA POL HEA PRE GOV"
  Expires: Wed, 11 Jan 1984 05:00:00 GMT
  Last-Modified: Fri, 20 Oct 2006 03:08:45 GMT
  Cache-Control: no-cache, must-revalidate, max-age=0
  Pragma: no-cache
  Connection: close
  Content-Type: text/html
Location: unspecified
ERROR: Redirection (302) without location.

I know I remember something about the header("Location:"); output with PHP-CGI, but I didn't think that was a problem in the past couple of years.

comment:10 @ev3rywh3re9 years ago

I just found this bug report about Fast CGI PHP with a lot of useful information and thought I might add it here:

PHP Bug #36705 Location header results in duplicate Status header

comment:11 @angelpb9 years ago

Hi,

Just installed WP 2.0.5 over Apache running PHP as fastcgi. Caught lot of "Internal Server 500" messages: After login, after every post...Anyway, posts got saved, so I started tracking the error and I finished in the wp_redirect function, specifically in the status /header pair of lines...Then I made a search in google and found this page. I removed the

status_header($status);

Line and...¡Voila! Everything is up and running. Just wanted to let you know how useful this entry has been to me and that bug is perfectly reproduced...

Regards from Spain,

Ángel
www.presionblogosferica.com
(this is NOT the domain I'm installing and testing right now, in case you wanted to figure out)

comment:12 @markjaquith9 years ago

Small number of people reporting problems with this. I think we should yank the status line.

Temporary solution: http://txfx.net/code/wordpress/wordpress-tuneup/wordpress-205-tuneup/

comment:13 @foolswisdom9 years ago

  • Keywords maint-candidate added

comment:14 @markjaquith9 years ago

  • Status changed from new to assigned

(In [4445]) possible solution for #3215

angelpb, ev3rywh3re, Xmion,

Can you please try trunk revision 4445, with any workaround solutions removed?

This thread lead me to believe that this might solve the problem.

comment:15 @ev3rywh3re9 years ago

Just reporting back for this. Using [4455] ( current to date ) still has issues.

Removing header_status from wp_redirect in pluggable.php line 273 fixes problem.

I know it has to do with php fast cgi version in use at Yahoo hosting, but I am unable to troubleshoot what php_sapi_name() is returning at this time. I may try to see what it's spitting out if I get a chance.

comment:16 @ryan9 years ago

  • Milestone changed from 2.1 to 2.0.6

comment:17 @ryan9 years ago

MarkJaquith, the PHP dev responding to php bug #36705 suggests using HTTP/1.1 instead of Status: for cgi. PEAR's HTTP_header class does the same thing. This is contrary to what folks have been doing for awhile now. See #2628, for example.

Maybe we should just skip status_header() for 'cgi-fcgi' SAPIs. For 2.1, we could consider bumping the PHP requirement to 4.3 so that we can use the extra args to header().

comment:18 @markjaquith9 years ago

[4513] and [4514]

Doing HTTP/1.1 for CGI, and skipping status_header() for 'cgi-fcgi'. I have a contact with access to a number of affected hosts, and I'll have him test.

comment:19 @shorty1149 years ago

Wouldn't this be a blocker?

comment:20 @markjaquith9 years ago

  • Severity changed from critical to blocker

Yes... blocker. I haven't heard anything since 11/22's commits, so I'm going to ping wp-testers

comment:21 @markjaquith8 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed
  • Version changed from 2.1 to 2.0.5

I've had two reports that this has was fixed by [4513] and [4514]

I just got access to a PHP 5.2 FastCGI install and verified it for myself.

comment:22 @marcfonteijn8 years ago

I'm experiencing this issue in 2.0.9. The difference with the original description is that I only get a blank screen after the login. Everthing else looks to be working fine.

comment:23 @foolswisdom8 years ago

marcfonteijn, best to open a new ticket referencing this one, including all clues that you can think of including your PHP version, if this is a new installation, or an upgrade, a screenshot of the symptom.

comment:24 @abischof8 years ago

  • Cc abischof added

comment:25 @hakre5 years ago

The PHP Bug report shows a small test-scenario (at the end) to test wether or not your server is affected by this:

http://bugs.php.net/bug.php?id=36705

Note: See TracTickets for help on using tickets.