WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32156 closed defect (bug) (duplicate)

Input lag following 4.2.1 update

Reported by: MarioKnight Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.1
Component: Editor Keywords:
Focuses: ui, administration, performance Cc:
PR Number:

Description

Earlier today following the auto-update, it was reported to me that when editing a page with a high amount of text, when typing there is a delay from the keystroke to the visual of the key being pressed. This initially made no sense to me, as such things I believe were handled by the local machine, with nothing going to the server until the user saves or the autosave occurs each minute (or whatever the increment is set to). However, I was able to replicate this at my workstation. I had edited that page hours prior when the site was still 4.2 with no issues. I have also been able to replicate the issue on my personal laptop. It feels odd to report such a thing, but with two of us having the same behavior between three systems where the only change was the update from 4.2 to 4.2.1 (which I can confirm as I run the server). I'm not sure how I can state a good method for replication, I haven't determined what size threshold exists between no lag and lag. I can try to obtain any further information if someone can let me know what is needed. Thank you.

Change History (9)

#1 @peterwilsoncc
5 years ago

Hi @MarioKnight, welcome to trac.

Are you able to add the browser and operating systems you are using on your latptop and workstation. There is usually an "About <browser>" option in the menus to get the exact version.

Let us know if you can replicate in multiple browsers.

Thanks.

#2 @MarioKnight
5 years ago

Thank you for the welcome and quick response. I can't believe I forgot to check different browsers, I'm sorry about that. Here is what I've gathered.

Personal Laptop - Windows 7 64-bit
Google Chrome: Version 42.0.2311.90 m - Issue confirmed
Firefox: 35.0.1 - Issue confirmed though improved response time
Firefox: 36.0.4 - Issue confirmed though improved response time
Firefox: 37.0.2 - no issue (FF asked to update twice after tests hence multiple results)
Internet Explorer: 10.0.0.9 - no issue

Office Workstation - Ubuntu 12.04 LTS
Google Chrome: I believe 42 but will verify when I return to work tomorrow - Issue confirmed

#3 @netweb
5 years ago

  • Component changed from Administration to Editor
  • Version changed from 4.2 to 4.2.1

#4 @SergeyBiryukov
5 years ago

Might be related to #32128 / #32157 or #32125.

Last edited 5 years ago by SergeyBiryukov (previous) (diff)

#5 @MarioKnight
5 years ago

I'm at my office and can add more browser information

Office Workstation - Ubuntu 12.04 LTS
Chrome: Version 42.0.2311.90 (64-bit) - Issue confirmed
Chromium: Version 37.0.2062.120 Ubuntu 12.04 (281580) (64-bit) - no issue
Firefox: 37.0.2 - Issue confirmed though improved response time

#6 @MarioKnight
5 years ago

While I was poking around for information on another issue that was reported to me, I was able to see that this forum thread, https://wordpress.org/support/topic/visual-editor-not-working-after-42-upgrade , has reports of other users having the same issues as I have seen described above. While it seems like the browser reporting mostly lines up with some slight variations, it looks like @sunspot10 was able to make a correlation between the PHP version in use on a server and the issue. More specifically they report that PHP versions above 5.3.39 are showing the issues. I hope this can help some.

#7 @netweb
5 years ago

@MarioKnight,

I understand that the support topic you linked to may sound similar but I'm expecting that it will not be the same issue.

That issue is talking about the differences between 4.1.x and 4.2.x, you original report when creating this ticket stated your issue was a difference between 4.2 and 4.2.1.

I haven't looked at what the actual cause of the issue might be, there's a few things going on at the moment in preparation for a 4.2.2 release, what we do need to clarify here in this ticket though is if this is in fact a 4.2 -> 4.2.1 issue, or is it a 4.1.x - 4.2 issue.

#8 @MarioKnight
5 years ago

@netweb,

Understood. Then taking the similar forum post out of the equation, the issue I reported yesterday is a 4.2 to 4.2.1 issue. I edited a page yesterday morning with no issues, and then someone else was editing the same page about a half hour after 4.2.1 was applied and noticed the input lag. I checked on the same browser and machine that I had used earlier and had the same issue, and later on is where I made this ticket.

#9 @Otto42
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32197.

Note: See TracTickets for help on using tickets.