Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#32157 closed defect (bug) (duplicate)

Emoji script: infinite loop when image does not load

Reported by: iseulde Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Formatting Keywords:
Focuses: Cc:

Description

Twemoji replaces images that do not load with the original text, which is detected by our mutation observer that parses any added text nodes. If the image never loads there will be an infinite loop.

To fix this we’ll have to look at the removed nodes in the mutation record and return if twemoji is replacing an image with the text in the alt attribute.

Attachments (1)

32157.patch (1.0 KB) - added by iseulde 7 years ago.

Download all attachments as: .zip

Change History (2)

@iseulde
7 years ago

#1 @SergeyBiryukov
7 years ago

  • Milestone 4.2.2 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32128.

Note: See TracTickets for help on using tickets.