WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#32168 closed feature request (duplicate)

Add start and count attributes to gallery shortcode

Reported by: frymi Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.1
Component: Gallery Keywords: has-patch
Focuses: Cc:

Description

Add shotcodes COUNT for views full gallery after click on MORE. Home
Modify files ./wp-includes/media.php
Lines 699 (add COUNT => '-1')
Lines 767-798 (add ForEach ... )
Use in WP:
[gallery] ... show standard gallery
OR
[gallery count=3] ... show images 1-3
more -
[gallery count=3+] ... show images 4-n

Attachments (2)

media-421.path (2.9 KB) - added by frymi 6 years ago.
./wp-includes/media.php
media-421-change.path (2.3 KB) - added by frymi 6 years ago.
./wp-includes/media.php

Download all attachments as: .zip

Change History (6)

@frymi
6 years ago

./wp-includes/media.php

@frymi
6 years ago

./wp-includes/media.php

#1 @frymi
6 years ago

  • Keywords has-patch added

#2 @pavelevap
6 years ago

Duplicate #11725?

#3 follow-up: @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #11725.

#4 in reply to: ↑ 3 @frymi
6 years ago

Replying to SergeyBiryukov:

Duplicate of #11725.

This is a modification for new version WP 4.2.1
In previous versions can not be set higher than the version 2.9.x

When it can be assumed that implementation?
Thanx

Note: See TracTickets for help on using tickets.