Make WordPress Core

Opened 17 years ago

Closed 17 years ago

Last modified 18 months ago

#3218 closed defect (bug) (duplicate)

submenu style

Reported by: mdawaffe's profile mdawaffe Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: Administration Keywords: has-patch has-unit-tests
Focuses: Cc:

Description

FF screengrab attached.

(This might be a dupe - couldn't find it, though)

Attachments (1)

Picture 15.png (13.9 KB) - added by mdawaffe 17 years ago.

Download all attachments as: .zip

Change History (19)

@mdawaffe
17 years ago

#1 @Sewar
17 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3149, and it has a patch.

#2 @matt
17 years ago

I think this is addressed in #3149.

#3 @Nazgul
17 years ago

  • Milestone 2.1 deleted

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


6 years ago

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


5 years ago

This ticket was mentioned in Slack in #core-editor by nrqsnchz. View the logs.


3 years ago

This ticket was mentioned in PR #3254 on WordPress/wordpress-develop by andrewserong.


18 months ago
#7

  • Keywords has-patch added

❗ BLOCKED by #3218 (that PR will output the layout styles generated by this PR)

This PR is a follow-up to https://github.com/WordPress/wordpress-develop/pull/3205 and backports the remaining parts of the layout block support.

## To-do

  • Backport tests
  • Ensure it's working on top of #3218

Trac ticket:

andrewserong commented on PR #3254:


18 months ago
#8

@tellthemachines I believe this one is working correctly — it just depends on https://github.com/WordPress/wordpress-develop/pull/3218 in order for the generated styles to be output.

This ticket was mentioned in PR #3262 on WordPress/wordpress-develop by andrewserong.


18 months ago
#9

  • Keywords has-unit-tests added

This is another fork of #3218, to attempt to fix the tests that are broken in #3259.

Original PR desc:

Backporting changes to script-loader that enqueue block support styles stored by the style engine/

See tracking issue: https://github.com/WordPress/gutenberg/issues/43440

Backporting the following changes

Trac ticket:

andrewserong commented on PR #3254:


18 months ago
#10

Thanks for all the feedback @costdev! I believe I've implemented it all, so this should be ready for another look now 🙂

andrewserong commented on PR #3254:


18 months ago
#11

Alrighty, now that https://github.com/WordPress/wordpress-develop/pull/3273 has landed, it looks like this one should be good to commit now CC: @ockham

andrewserong commented on PR #3254:


18 months ago
#13

I've given this a rebase, and confirmed that it's still working correctly on top of trunk 👍

hellofromtonya commented on PR #3254:


18 months ago
#14

I'm self-assigning for review and commit.

costdev commented on PR #3254:


18 months ago
#15

## Test Report

### Steps to Test

  1. Apply the PR.
  2. Activate the Twenty Twenty-Two theme. Ensure that there are no header customizations in the Site Editor.
  3. Navigate to the frontend.
  4. Inspect the header row.

### Expected Results

  • ✅ The element should now have the .is-layout-flex class.
  • ✅ The styling should match that shown in the screenshot in the PR's description.

### Environment

  • Server: Apache (Linux)
  • WordPress: 6.1-alpha-53344-src
  • Browser: Chrome 105.0.0.0
  • OS: Windows 10
  • Theme: Twenty Twenty-Two
  • Plugins: None activated.

### Actual Results

  • ✅ The element has the .is-layout-flex class.
  • ✅ The styling matches that shown in the screenshot in the PR description.

### Supplemental Artifacts
https://i0.wp.com/user-images.githubusercontent.com/79332690/191379850-27f9519f-e809-443a-b061-3d923fb77415.jpg

hellofromtonya commented on PR #3254:


18 months ago
#16

For this backport, I'll be reverting the DocBlock changes for wp_get_layout_style(). Why?

Instead, I'll do a follow-up coding standards commit to improve the DocBlock including updating the descriptions for the optional parameters (e.g. adding the word Optional. and adding the default Default is null.).

hellofromtonya commented on PR #3254:


18 months ago
#17

Committed via changeset https://core.trac.wordpress.org/changeset/54274. Thank you everyone for your contributions!

A follow-up commit is coming to address other changes that were not part of the original GB PR (such as DocBlock improvements).

hellofromtonya commented on PR #3254:


18 months ago
#18

DocBlock improvements suggestioned in this PR were committed via changeset https://core.trac.wordpress.org/changeset/54275.

Note: See TracTickets for help on using tickets.