WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32188 closed defect (bug) (duplicate)

embed handler doesn't match URLs with query strings

Reported by: paulschreiber Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: General Keywords:
Focuses: Cc:
PR Number:

Description

WordPress' embed handler doesn't match URLs with query strings.

If you paste a URL with a query string in it into the body of a post, you are shown the raw URL

http://example.com/foo.mp3 <-- becomes an MP3 player
http://example.com/foo.mp3?some=thing&other=thing <-- shows up as a raw URL

Change History (1)

#1 @johnbillion
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #30377.

Note: See TracTickets for help on using tickets.