WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#32232 closed defect (bug) (fixed)

Twenty Twelve: Skip Link Does Not Appear on :focus

Reported by: davidakennedy Owned by: lancewillett
Milestone: 4.3 Priority: normal
Severity: normal Version: 4.3
Component: Bundled Theme Keywords: has-patch
Focuses: accessibility Cc:

Description

To replicate:

  1. Navigate to #content link with keyboard using tab key.
  2. Link does not appear.

You'll see:

https://cloudup.com/cRkIbYoMvvs

It looks like a height and width need to be set on :focus to override the:

height: 1px;
width: 1px;

Related #32231

Attachments (1)

32232.patch (454 bytes) - added by davidakennedy 7 years ago.
Set height and width on skip-link :focus.

Download all attachments as: .zip

Change History (6)

@davidakennedy
7 years ago

Set height and width on skip-link :focus.

This ticket was mentioned in Slack in #accessibility by davidakennedy. View the logs.


7 years ago

#2 @afercia
7 years ago

  • Keywords has-patch added

#3 @lancewillett
7 years ago

  • Milestone changed from Awaiting Review to 4.3

#4 @lancewillett
7 years ago

Confirmed patch fixes the reported issue.

#5 @lancewillett
7 years ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 32486:

Twenty Twelve: fix content skip link appearance.

Props davidakennedy, fixes #32232.

Note: See TracTickets for help on using tickets.