WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#32245 closed defect (bug) (duplicate)

wp_list_categories and maximum execution time error

Reported by: hadi060 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.1
Component: Taxonomy Keywords:
Focuses: performance Cc:
PR Number:

Description (last modified by SergeyBiryukov)

Hi.
I'm facing a problem when using wp_list_categories function. Website take a long time to load, and this error message appears in most of the time:

Fatal error: Maximum execution time of 30 seconds exceeded in
mywebsite.com/wp-includes/taxonomy.php on line 3958.

I'm using the function as follows:

wp_list_categories('orderby=id&hide_empty=0&depth=1&title_li=&use_desc_for_title=1&child_of=1');

It was working just fine, until the last WordPress update as I think.
As I see, it's the same problem with get_terms posted here: #32144

and there are many website look having the same issue when searching on google for: "wp-includes/taxonomy.php on line 3958".

Search results:
http://goo.gl/vQSzQo

Hope you fix that, and sorry for my bad English.

Change History (2)

#1 @SergeyBiryukov
4 years ago

  • Description modified (diff)

#2 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32144.

Note: See TracTickets for help on using tickets.