WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#32271 closed defect (bug) (duplicate)

Permalink is displayed for not publicly queryable posts

Reported by: ipm-frommen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords: has-patch
Focuses: administration Cc:

Description

TLDR: Why would I want to see a permalink (and have a button linking to it) if the link doesn't work?


Currently, the permalink section when editing a post in the WordPress admin is displayed depending on the value of the according post type's public parameter/property.

In my opinion, this is a bug, and should thus be changed to be using the publicly_queryable parameter/property instead. In case this parameter/property is not explicitly set in the according register_post_type call, it will implicitly be set to the value of the public parameter/property.

Please find the attached patch.

Attachments (1)

32271.patch (723 bytes) - added by ipm-frommen 6 years ago.

Download all attachments as: .zip

Change History (3)

@ipm-frommen
6 years ago

#1 @ipm-frommen
6 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17609.

Note: See TracTickets for help on using tickets.