WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#32283 closed defect (bug) (invalid)

Selecting Widgets From Top WordPress Bar Takes You To Customize Instead

Reported by: Brian Ash Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Customize Keywords:
Focuses: Cc:

Description

For the last few versions of WordPress, whenever you select Widgets from the drop down menu underneath your website name on the top WordPress bar, instead of it taking you to the Widgets page, it takes you to the Customize page instead (see screenshot).

http://swimmingpoolservicespringfieldmo.com/wp-content/uploads/2015/05/WordPress-Screenshot.jpg

If you try it yourself, you should see what I mean.

Attachments (1)

WordPress Screenshot.jpg (127.0 KB) - added by Brian Ash 6 years ago.
This screenshot shows the option that isn't working correctly

Download all attachments as: .zip

Change History (6)

@Brian Ash
6 years ago

This screenshot shows the option that isn't working correctly

#1 follow-up: @ocean90
6 years ago

  • Component changed from Editor to Customize
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 4.2.2 to 4.2

Hello Brian Ash, welcome to Trac.

The link to the widgets panel of the Customizer was introduced in [31176] and is by design. For background take a look at #30971.

#2 in reply to: ↑ 1 @Brian Ash
6 years ago

Replying to ocean90:

Hello Brian Ash, welcome to Trac.

The link to the widgets panel of the Customizer was introduced in [31176] and is by design. For background take a look at #30971.

Yeah, I just figured out this was by design. It was throwing me because it takes a second (or two or three) to transition from Customizing the Theme to Customizing the Widgets when you select it.

I'm not a big fan of the Customize feature in general, so I liked how it worked before better. Now when I'm working with Widgets, I'll have to hit Dashboard and then find the Widgets option under the Appearance menu. More steps, but I'll eventually get used to that.

When I'm working with Widgets, I sometimes like to open several of them up and copy HTML from one Widget to another, but Customize only lets you have one Widget open at a time. I like having the full widgets page at my disposal with more real estate.

Just like how selecting Menu takes you to the Menu page, I wish selecting Widgets still took you to the Widgets page. Maybe if enough people complain it will change back (not holding my breath though)...

Thanks for the quick response.

#3 @dmchale
6 years ago

  • Component changed from Customize to Editor
  • Version changed from 4.2 to 4.2.2

While I understand why this was done, it seems to provide an inconsistent usability issue for users. The options in the top nav used to mimic the functionality of their counterparts in the "Appearance" menu of the backend... now that "Themes" and "Widgets" have been hijacked for their new customizer flavors from the frontend dropdown, I wonder how difficult it may be for some users to find the tools where they can ADD themes and manage their widgets with the traditional "drag-n-drop" area.

#4 @ocean90
6 years ago

  • Component changed from Editor to Customize
  • Version changed from 4.2.2 to 4.2

This ticket was mentioned in Slack in #core-customize by celloexpressions. View the logs.


6 years ago

Note: See TracTickets for help on using tickets.