WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#32321 closed enhancement (duplicate)

Localize forgot password link

Reported by: spacedmonkey Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords:
Focuses: multisite Cc:

Description

So in wordpress multisite, the forgotten password experience is a little weird. Take for example the following example from a standard sub domain install.

  1. User goes to the admin terminal for their site test.example.com/wp-login.php
  2. Clicks on forgotten password link. They are then taken to www.example.com/wp-login.php?action=lostpassword

This is confusing, as the url has changed. The user may see this as a mistake or phishing attempt. This is then compounded if the site is using domain mapping. The user could be directed from www.mysite.com/wp-login.php www.anotheraite.com/wp-login.php?action=lostpassword

The forgotten password should link to the current site url. i.e

test.example.com/wp-login.php?action=lostpassword

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Focuses multisite added
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21352.

Note: See TracTickets for help on using tickets.