WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#32336 closed enhancement (wontfix)

Add Class to Remove Dependence on HEntry

Reported by: dshanske Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords: close
Focuses: Cc:

Description

Hentry is a microformat class. However, because it is the only class that appears on 100% of posts, it is often used for styling. This has created a dependence on hentry for styling which creates an issue for having this changed in the future to address the improper use of hentry.

Microformat classes shouldn't be used for styling for this reason, but there is no alternative. Proposing a generic container class to be used for styling to slowly deprecate the practice.

Attachments (1)

32336.1.diff (463 bytes) - added by peterwilsoncc 4 years ago.

Download all attachments as: .zip

Change History (11)

This ticket was mentioned in Slack in #core by peterwilsoncc. View the logs.


4 years ago

#2 @peterwilsoncc
4 years ago

  • Type changed from defect (bug) to enhancement

32336.1.diff adds the class entry.

I like this, it allows themes/plugins to use other structured data formats without affecting styling. entry is a straw man, article or post could arguably be equally valid.

#4 @obenland
4 years ago

  • Keywords close added

The premise for this ticket is that .hentry might be changed in the future—which it will not, for the very reason that was outlined above, themes rely on it being there.

.hentry won't go anywhere, so I don't see the benefit of introducing yet another, even more arbitrary, class. Apart from that, there is now an abundance of possibilities for theme authors to apply styles to all posts (including using more than one selector), I'm not sure we really need a new class for that.

#5 @johnbillion
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I concur. .hentry shouldn't have been used for styles, but it has been for years, and therefore it won't be going anywhere.

#6 @dshanske
4 years ago

The issue is that by relying on it, we make it so that the hentry can't be removed by a plugin or other action without changing the theme.

Accepting that it won't change for past themes...I was hoping at least the dependence on hentry for styling could change for future themes, or even the existing themes bundled with WordPress.

#7 follow-up: @dshanske
4 years ago

Before I ask it, in the bundled 2012-2015 themes, which serve as examples to the community, would the removal of the hentry as a styling element be worth proposing?

#8 in reply to: ↑ 7 @obenland
4 years ago

Replying to dshanske:

Before I ask it, in the bundled 2012-2015 themes, which serve as examples to the community, would the removal of the hentry as a styling element be worth proposing?

I don't see why not.

This ticket was mentioned in Slack in #core-themes by iamtakashi. View the logs.


4 years ago

This ticket was mentioned in Slack in #core-themes by obenland. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.