Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#32338 closed defect (bug) (duplicate)

Wp-emoji-script causes a js error in ie, ie11

Reported by: pavelthq's profile pavelthq Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: General Keywords:
Focuses: ui, javascript Cc:

Description

// Source: wp-includes/js/wp-emoji.min.js
!function(a,b){function c(){function c(){if(!i){if("undefined"==typeof a.twemoji){if(j>600)return;return a.clearTimeout(f),f=a.setTimeout(c,50),void j++}e=a.twemoji,i=!0,g&&new g(function(a){for(var b,c,e,f,g=a.length;g--;){if(b=a[g].addedNodes,c=a[g].removedNodes,e=b.length,1===e&&1===c.length&&3===b[0].nodeType&&"IMG"===c[0].nodeName&&b[0].data===c[0].alt)return;for(;e--;)f=b[e],3===f.nodeType&&(f=f.parentNode),!f||f.className&&-1!==f.className.indexOf("wp-exclude-emoji")

In ie:
f.className
is an object that has two keys:
animVal
baseVal

but it doesn't have a method: indexOf. In my console it causes an error and prevent next script execution.

http://by-blickwinkel.de/test-page/

Change History (2)

#1 @peterwilsoncc
9 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32305.

#2 @DrewAPicture
9 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.