WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#32347 closed defect (bug) (worksforme)

Saving Menu Breaks Cyrillic Characters

Reported by: lordspace Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Menus Keywords: reporter-feedback
Focuses: Cc:

Description

When saving the Menu Structure Cyrillic characters do not come back as they should have.

Video showing the issue: http://youtu.be/yjP3qCmC19Y

Change History (7)

#1 @lordspace
6 years ago

mysql> show variables like "character_set_database";
+------------------------+-------+
| Variable_name | Value |
+------------------------+-------+
| character_set_database | utf8 |
+------------------------+-------+
1 row in set (0.00 sec)

mysql> show variables like "collation_database";
+--------------------+-----------------+
| Variable_name | Value |
+--------------------+-----------------+
| collation_database | utf8_general_ci |
+--------------------+-----------------+
1 row in set (0.00 sec)

#2 @SergeyBiryukov
6 years ago

  • Keywords reporter-feedback added

Hi @lordspace, thanks for the report.

I could not reproduce the issue on a clean install. Does it still happen with all plugins disabled and a default theme (Twenty Fifteen or Twenty Fourteen) activated?

#3 follow-up: @lordspace
6 years ago

I just setup a fresh install too and the issue wasn't there.

The test site I showed in the demo was just upgraded from 4.1.
Does it mean that the upgrade process missed something?

#4 in reply to: ↑ 3 @SergeyBiryukov
6 years ago

Replying to lordspace:

Does it mean that the upgrade process missed something?

Well, the upgrade routine tries to convert utf8 to utf8mb4, but I don't think it has anything to do with this issue.

This looks like either a plugin issue or some kind of server configuration issue to me. Are regular post titles saved correctly on that install?

#5 @lordspace
6 years ago

Nope. It's a not a plugin interfering.
There were 2 installed plugins on that sandbox site and 1 mu plugin.
I uninstalled all of them

Last edited 6 years ago by samuelsidler (previous) (diff)

This ticket was mentioned in Slack in #core by afercia. View the logs.


6 years ago

#7 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No other reports in almost 2 years. Feel free to reopen if there's still an issue.

Note: See TracTickets for help on using tickets.