WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32375 closed enhancement (duplicate)

Ability to Completely disable comments

Reported by: Another Guy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: needs-patch ux-feedback
Focuses: Cc:
PR Number:

Description (last modified by SergeyBiryukov)

This one goes back as far as #4222.

The idea is to have a master "on/off" for comments. With wordpress more and more being used for corporate sites or display sites that have no provision (or desire) for reader feedback on individual items, it seems wasteful and perhaps even somewhat insecure to continue to allow comments to even enter into the system.

On a functionality level, a single checkmark on the discussion page at the very top would e "comments enabled disabled for entire site". If checked, all other options would be greyed out and comment processing would be removed from the admin menu (not required).

Also, either a new API call (comments_disabled) or an extra option in have_comments to allow theme designers to allow for the idea that comments might not exist at all on a site, and not to even bother running code of including templates for comments.

Finally, it should also automatically disable and refuse connections for anyone trying to force comments / spam / directly post comments. This would lower server load and limit the effects of spammers on sites that just do not have any comment processing enabled.

Change History (2)

#1 @johnbillion
5 years ago

  • Keywords needs-patch ux-feedback added
  • Type changed from defect (bug) to enhancement

This is probably a duplicate of an existing ticket, but I agree. I actually think we should do this.

I'd also love to have more control over comments on a per-post-type basis, but that's out of scope for this issue.

#2 @SergeyBiryukov
5 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27111.

Note: See TracTickets for help on using tickets.