WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#32379 closed defect (bug) (duplicate)

Updating private post type shows public link in message

Reported by: ashworthcreative Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

Whenever you update or publish a post from a private post type, the message "Post updated. View post" is displayed, with the text "View post" as a permalink to the current post. This message ignores the singular_name and view_item labels for the post type, and the link itself is unnecessary and for private post types, where it will always link to a 404 page.

Change History (3)

#1 @utkarshpatel
4 years ago

Hey ashworthcreative,

In Case of CPT one can use post_updated_messages filter to add own message when custom post is updated also while registering post type if you have set 'public' => false you won't see permalink.

#2 @ashworthcreative
4 years ago

I do have public set to false. That's why I filed the ticket, because the permalink still shows. Why wouldn't the messages use the appropriate post type labels by default, if they exist? That functionality should be the default behavior.

#3 @johnbillion
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report ashworthcreative. This is indeed a bug but it's a duplicate of an existing ticket: #17609.

Note: See TracTickets for help on using tickets.