WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#32397 closed defect (bug) (duplicate)

Remove Email To Post Feature

Reported by: chriscct7 Owned by: chriscct7
Milestone: Priority: normal
Severity: normal Version:
Component: Mail Keywords:
Focuses: Cc:
PR Number:

Description

The email to post feature has many bugs, and currently does not work for the vast majority of usecases as the version in core requires an http mailserver (it does not support an https one).

The goal is to remove the entire feature from core for all installs (as it simply doesn't work) including the associated file and settings and move them to a plugin that Kat nearly completed a while ago. On install of 4.3, if one of the options for the mail to post is set to a non default value, we'll automatically download and activate the new version of the plugin which fixes the bugs and supports https mailservers from WordPress.org.

Will tag related tickets here in a sec.

A patch for this has been started

Change History (3)

#1 @chriscct7
5 years ago

  • Owner set to chriscct7
  • Status changed from new to assigned

#2 @chriscct7
5 years ago

  • Component changed from General to Mail

Related tickets:

Removal of settings: #32396

Bugs:
#4337, #4965, #5252, #22942, #19984,

Last edited 5 years ago by chriscct7 (previous) (diff)

#3 @ocean90
5 years ago

  • Keywords needs-patch removed
  • Milestone 4.3 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #22942.

Note: See TracTickets for help on using tickets.