WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32407 closed defect (bug) (invalid)

Disable formatting html

Reported by: freetheweb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:
PR Number:

Description

I cannot tell you the number of times I have been forced to disable the visual editor because it screws up my HTML. This is a widespread problem for many people. WordPress is, and has been for a while, a fantastic piece of open source software that is made to work for pretty much anyone and anything.

Can we please finally be rid of the few serious oddities it has, one of which is this?

Shortcodes have been a godsend for this reason, but then the visual editor (which is supposed to be visual) becomes a mass of code.

Let us add whatever HTML we want and be sure that WordPress won't touch it.

Change History (3)

#1 follow-up: @johnbillion
5 years ago

  • Keywords reporter-feedback added

Thanks for the report freetheweb.

Can you be more specific? Can you provide an example of some markup which gets "screwed up"?

#2 in reply to: ↑ 1 @freetheweb
5 years ago

Replying to johnbillion:

Thanks for the report freetheweb.

Can you be more specific? Can you provide an example of some markup which gets "screwed up"?

I don't remember specifically since I've moved on to using only shortcodes instead for this reason. However, it is a wide know issue. If you Google it you'll find a lot of posts about how annoying it is.

One example: http://wordpress.stackexchange.com/questions/17123/keep-html-format-when-switching-from-visual-to-html-editor

#3 @iseulde
5 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.2.2 deleted

I don't remember specifically since I've moved on to using only shortcodes instead for this reason. However, it is a wide know issue. If you Google it you'll find a lot of posts about how annoying it is.

Could you please create a separate ticket for each issue? A vague and general ticket without specifying what's wrong exactly is not very helpful. If you remember any issues and you can give steps to reproduce, please don't hesitate to create a new ticket.

Note: See TracTickets for help on using tickets.