WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 months ago

#32438 closed defect (bug) (invalid)

Drag & Drop media uploader breaks in FireFox Developer Edition 40.0a2 (2015-05-18)

Reported by: Jacotheron Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Upload Keywords:
Focuses: Cc:

Description

Summary:
When dragging the image into the drop area, the file is added to the list to upload, but the upload never happens - Immediate "HTTP error"

What have I tried:
I debugged the WordPress install using the recommended methods (disabled plugin, modifying chmod, added .htaccess rules, increased memory, increased upload & post sizes, tested on different servers including production, staging, and local vagrant installs). Nothing works, although it previously worked.

I continued the debugging, and found that:

  1. Browser Uploader works
  2. Clicking inside the Drag & Drop area and select image(s) works
  3. Dragging any file into the Drop area resulted in an immeditate "HTTP error"

I continued to compare the requests (using FireBug) - they are identical (only difference was the boundry value). Their Post data length was the same (although I was not able to see and compare the data itself).

In the Dragged File's request, there was no response (request is sent, but no reply, not even response headers). I even modified the receiving php file to quit immediately with a message (message did not come through). Making a manual request to the receiving file resulted in a WordPress branded error (which is expected).

I continued and tested it in my other browsers, all other browsers worked as expected.

Conclusion:
It affects only FireFox Developer Edition (after it updated to version 40.0a2).

Possible Cause:
It could be a change in how Firefox handles files being dropped onto a website.

Additional Info:
This issue also affects other websites (like Shopify specifically), however Google have already solved it on Google+ (which is why I believe it is just a minor change in Firefox's API; if it is an API change, it would be nice to have it work when Firefox Stable updates in about 5-6 weeks).

I am using a Windows computer for Firefox, WordPress 4.2.2 (running on Linux installs, either via VVV, or Remotely), PHP versions 5.5 and 5.6, Apache and Nginx servers.

I tried multiple different files, file types and file sizes, works only when selecting through the file selection interface.

Change History (8)

#1 @helen
3 years ago

I'm on 40.0a2, build 20150517004004 - not able to reproduce on OSX. Perhaps specific to Windows, though - would be nice if somebody else could test that.

#2 @anubisthejackle
3 years ago

http://i58.tinypic.com/30lcso7.png

Duplicated on Windows 8.

#3 @miketaylr
3 years ago

Hi Jacotheron, do you happen to know if you enabled e10s (the new multiprocess stuff)? Can you test again from a non-e10s window? There should be an option like File > New non-e10s Window (I think).

#4 @anubisthejackle
3 years ago

@miketaylr - I can confirm that e10s was not enabled in my test.

#5 @Jacotheron
3 years ago

In my report, initial issue detection, all tests and debugging were done with e10s enabled.

As per @miketaylr I tested again with e10s disabled, it worked.

I have the issue on 2 computers, (Windows 8.1 Update 64bit and Windows 7 Professional SP1 64bit).

Using e10s disabled (if it works) is an acceptable workaround for now.

#6 @helen
3 years ago

@anubisthejackle Working on a trust-but-verify philosophy, could you possibly re-test as well? We've got a couple lovely Mozilla/Firefox compat people with eyes on this, want to make sure they don't need to further tear their hair out :)

#7 @anubisthejackle
3 years ago

@helen - Just updated to the daily build of Dev and can confirm this no longer seems to be an issue.

#8 @azaozz
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing as per comment 7.

Note: See TracTickets for help on using tickets.