WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#32441 closed defect (bug) (invalid)

Unable to install plugins on DesktopServer

Reported by: interglobalmedia Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

Hi,

I am using DesktopServer for my local Wordpress development environment, and it seems that I am not able to successfully install any plugins at the moment. I have Jetpack installed, but I can't connect with Wordpress.com. I tried to install a plugin called Free Quotations which works perfectly fine on a live production site of mine with 4.2.2, but got a fatal error message when I tried to install in my development environment. Don't know if this is a Wordpress or a Desktop Server issue, but there is something wrong or incompatible going on here. I am on DesktopServer 3.8. This version was released over the weekend. May 15, 20 be exact. I have also alerted ServerPress about the issue. I am also on Wordpress 4.2.3 alpha. Thanks!

Best regards,

Maria Campbell

Change History (7)

#1 @johnbillion
6 years ago

  • Keywords reporter-feedback added
  • Summary changed from Bug with 4.2.3 alpha to Unable to install plugins on DesktopServer

Thanks for the report Maria.

  • Can you be a bit more specific about the issues?
  • Are you seeing any errors messages when trying to install or activate a plugin?
  • Do you have any errors in your PHP or server logs?
  • What steps can someone else try to reproduce the problems?
  • Were you previously successfully using DesktopServer? If so, this sounds like an issue with DesktopServer.

#2 @swissspidy
6 years ago

Also note that you cannot connect a local development site with WordPress.com as WP.com can't see your local site. Use Jetpack in Development Mode instead.

#3 @interglobalmedia
6 years ago

@johnbillion and @swisspidy,

Thanks for getting back to me. Yes, that's right about Jetpack. I was using a new development environment, and it did not indicate anything about that. Possibly then there is a glitch there (insufficiency or inefficiency) for starters. With MAMP, it immediately puts you in Jetpack in Development Mode (I tested in MAMP). SO it might have been a DesktopServer issue after all, because they had a new release this weekend, and maybe it wasn't playing nice with 4.2.3.

No way then to really know which is the complete culprit, but there is definitely some kind of incompatibility going on between DesktopServer and Wordpress 4.2.3. I will tell the guy I know there about this as well. Good thing I didn't pay for this environment! Hope this helps.

Currently on MAMP I'm at 4.2.2.

Best regards,

Maria

#4 @johnbillion
6 years ago

Thanks for the update. Without further information we have to assume that this is an issue with DesktopServer. Please let us know once the folks at DesktopServer get back to you.

#5 @interglobalmedia
6 years ago

Hi @johnbillion,

I went in to check out my theme situation in MAMP. There are no deprecated calls there, and everything seems in order. Hope this helps.

Best regards,

Maria

#6 @Steveorevo
6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Sounds like an OS permissions issue; please check with ServerPress.com to resolve. DesktopServer does not inhibit plugin installation. Please close here.

#7 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.