WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32501 closed defect (bug) (worksforme)

Comment section gives url error

Reported by: pchestek Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Comments Keywords:
Focuses: Cc:

Description

The comment function has fields labeled "Your name," "Your email" and "Your website." If one enters in the "Your website" field a domain name, e.g., "chestek.com" or "www.chestek.com" then you get an error that says "Please enter a url" and the comment won't be submitted. If you delete the web address altogether, or type "http://chestek.com" then you can submit the comment. But having to type "http://" surely can't be right, it certainly foiled my commenters.

Thanks!

Change History (1)

#1 @rmccue
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hmm. I just tried this with example.com without the HTTP and it worked fine for me. In fact, you should be able to enter almost anything in there; Hello World works fine, although it gets changed to http://helloworld/ via the sanitisation. There's definitely no message that I can see for invalid URLs, and in fact the text "Please enter a URL" does not appear in WordPress core.

This may be a plugin causing the strict checking, or a theme. I'd suggest asking on the [support forums](https://wordpress.org/support/) to debug what's causing this problem.

Thanks for the bug report!

Note: See TracTickets for help on using tickets.