WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#32514 closed defect (bug) (duplicate)

Shiny updates fails silently when it should return an error

Reported by: toddlahman Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

On the Plugins screen a plugin update is available:

https://www.dropbox.com/s/sa8gg6j34sauxhf/Screenshot%202015-05-27%2020.05.10.png

Using the "update now" link triggers the update, and the script response is "Updated!," however, the plugin update failed without an error being displayed.

https://www.dropbox.com/s/h8hhsnt7dsywr6q/Screenshot%202015-05-27%2020.05.38.png

On the Dashboard > Updates screen an update is available:

https://www.dropbox.com/s/qpey6o4fpisfkj6/Screenshot%202015-05-27%2020.06.18.png

When the update fails an error message is displayed indicating the problem:

https://www.dropbox.com/s/3ukzv3hdwv1hf90/Screenshot%202015-05-27%2020.06.38.png

Change History (4)

#1 @toddlahman
3 years ago

Not sure why the dropbox link didn't work using www.dropbox.com, so had to switch to dl.dropboxusercontent.com. Embeds are below in order.

https://dl.dropboxusercontent.com/s/sa8gg6j34sauxhf/Screenshot%202015-05-27%2020.05.10.png
https://dl.dropboxusercontent.com/s/h8hhsnt7dsywr6q/Screenshot%202015-05-27%2020.05.38.png
https://dl.dropboxusercontent.com/s/qpey6o4fpisfkj6/Screenshot%202015-05-27%2020.06.18.png
https://dl.dropboxusercontent.com/s/3ukzv3hdwv1hf90/Screenshot%202015-05-27%2020.06.38.png

#2 @dd32
3 years ago

Feels like a duplicate of #32473, but don't have a chance to test right now.

#3 @toddlahman
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32473.

Agreed. This does appear to be a duplicate.

#4 @netweb
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.