WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#32539 closed defect (bug) (duplicate)

Plugin naming issue

Reported by: warpdag Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:
PR Number:

Description

Hello there. We created a few plugins for our wordpress install ourselves, and were surprised yesterday when wordpress offered us to update one of our own plugins with a new version-- since these are internal it just didn't make any sense. It turns out a publicly available plugin was using the same name, and WP assumed the plugins were the same, while they clearly weren't. Renaming the title of the plugin within the plugin script wasn't sufficient, the only way to make this go away was to change the actual plugin file/directory names. Somehow WP seems to be relying only on plugin names to correlate/validate updates-- might be by design, but still, it could at the very least lead to the unintentional deletion of a site's plugins, and could potentially lead to much more serious issues.

Change History (1)

#1 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.2.2 deleted

Hello warpdag, thanks for your valid report, but we're already tracking this issue in #23318.

Note: See TracTickets for help on using tickets.