WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 2 weeks ago

#32583 closed defect (bug) (worksforme)

Bringing a sentence/word back a line deletes an underline and dissociates the text after it

Reported by: Moshe1010 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: TinyMCE Keywords: reporter-feedback
Focuses: rtl Cc:

Description

Hello,

When I want to bring a title of a paragraph a line up with a backspace on my keyboard, it deletes the underline on this word sentence and also dissociates the text that was connected to this word, creating a weird space in between (like it's not part of the paragraph anymore).

For more info: http://imagizer.imageshack.us/a/img673/9822/lDRTgk.gif

I'm on Chrome Version 43.0.2357.81 (64-bit), OS X 10.10.3

Thank you in advance.

Change History (4)

#1 @iseulde
4 years ago

  • Component changed from Editor to TinyMCE
  • Keywords reporter-feedback added

Thanks for the report. Could you give the exact steps to reproduce the problem? And describe what happens and what you expect to happen? Do you know if this also happens in left-to-right? No worries if you don't. :)

Since when does thin happen?

#2 @Moshe1010
4 years ago

Happens to me with LTR as well (on a RTL system overall; I don't have a clean WP LTR install).
Steps:

  1. Write a sentence/word as a title/headline to a paragraph (with changing any font size) in the middle of a page
  2. Press Shift+Enter to go a line down
  3. Write a 2-4 lines
  4. Bold and underline the title/headline of the paragraph
  5. Bring the headline/title only with a backspace a line up
  6. Notice how the underline disappear and the paragraph dissociates from the headline/title (I've attached a gif for more details in my initial post)

Thanks.

#3 @iseulde
4 years ago

  • Focuses rtl added

#4 @azaozz
2 weeks ago

  • Resolution set to worksforme
  • Status changed from new to closed

Unable to reproduce this in WP 5.2, seems it has been fixed upstream.

Closing as worksforme, feel free to reopen if still failing in some cases, but keep in mind this is superseded by the block editor.

Note: See TracTickets for help on using tickets.