WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 4 years ago

#32641 closed defect (bug) (invalid)

Editing and posting under Windows 10

Reported by: artayo Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

Error ROA POSTER 22 X 24.jpg
An error occurred in the upload. Please try again later.

Above is the error, when I upload. Not to mention I don't seem to have access to my gallery.

Windows 10 Home Insider Preview
Evaluation copy Build 10130

Attachments (3)

Capture 1.JPG (123.8 KB) - added by artayo 6 years ago.
upload error
Capture2.JPG (124.0 KB) - added by artayo 6 years ago.
media library
Capture3.JPG (199.2 KB) - added by artayo 6 years ago.
media library - this is after toggling views. so uploads but not able to see images.

Download all attachments as: .zip

Change History (15)

@artayo
6 years ago

upload error

@artayo
6 years ago

media library

@artayo
6 years ago

media library - this is after toggling views. so uploads but not able to see images.

#1 @artayo
6 years ago

  • Keywords ui-feedback needs-unit-tests needs-testing needs-patch ux-feedback added
  • Severity changed from normal to major

#2 follow-up: @SergeyBiryukov
6 years ago

  • Component changed from General to Media
  • Keywords reporter-feedback added; ui-feedback needs-unit-tests needs-testing needs-patch ux-feedback removed

Does the issue still happen with all plugins disabled and a default theme (Twenty Fifteen or Twenty Fourteen) activated?

#3 @ocean90
6 years ago

  • Severity changed from major to normal

#4 follow-up: @azaozz
6 years ago

Tested in Windows10 InsiderPreview 10130. The new Edge (Project Spartan) browser doesn't seem to support drag and drop from the desktop. Uploading works properly using the Select files button.

Chrome works properly in all cases, same as on Win7 or MacOS.

#5 in reply to: ↑ 2 @artayo
6 years ago

Replying to SergeyBiryukov:

Does the issue still happen with all plugins disabled and a default theme (Twenty Fifteen or Twenty Fourteen) activated?

Yes. I still get the error and am not able to see the media library.

Did find an interesting article, though. http://ideasandpixels.com/wordpress-media-library-not-working-solution

The author was dealing with an issue in version 3.9.1 regarding permissions for the media folder.

Last edited 6 years ago by artayo (previous) (diff)

#6 in reply to: ↑ 4 ; follow-up: @artayo
6 years ago

Replying to azaozz:

Tested in Windows10 InsiderPreview 10130. The new Edge (Project Spartan) browser doesn't seem to support drag and drop from the desktop. Uploading works properly using the Select files button.

Chrome works properly in all cases, same as on Win7 or MacOS.

I use Chrome as my primary browswer. Most of the functions work except drag and drop in Chrome.

#7 in reply to: ↑ 6 ; follow-up: @azaozz
6 years ago

Replying to artayo:

Sounds like there may be a JS error somewhere. Can you open the browser console, clear cache and try both drag/drop and Select files button to upload. Also, does the same site work in Project Spartan and Firefox?

#8 in reply to: ↑ 7 ; follow-up: @artayo
6 years ago

Replying to azaozz:

Replying to artayo:

Sounds like there may be a JS error somewhere. Can you open the browser console, clear cache and try both drag/drop and Select files button to upload. Also, does the same site work in Project Spartan and Firefox?

Tried that to no avail. Went as far as downloading jdk-8u45-windows-x64 from http://download.oracle.com/otn-pub/java/jdk/8u45-b15/jdk-8u45-windows-x64.exe?AuthParam=1434413173_9f7d9f23de3e619e9b6f1e4b298028fd and restarting all browsers. Changed the directory for the bin folder and checked in cmd to make sure the java library was running. All lights green. But went back to site still no good. Still not seeing media library, getting error when uploading and not able to attach to a post.I just get the wheel spinning by the search box. Was able to log into site from Spartan, Safari, and Firefox with the same error.

Last edited 6 years ago by artayo (previous) (diff)

#9 in reply to: ↑ 8 ; follow-up: @SergeyBiryukov
6 years ago

Replying to artayo:

Tried that to no avail. Went as far as downloading jdk-8u45-windows-x64

You don't need JDK, see https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors.

#10 in reply to: ↑ 9 @artayo
6 years ago

Replying to SergeyBiryukov:

Replying to artayo:

Tried that to no avail. Went as far as downloading jdk-8u45-windows-x64

You don't need JDK, see https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors.

thank you I will. there seems to be a common problem on another ticket. [WordPress Trac] #32654: Denying upload_files cap makes Customizer and Media modal act oddly

BTW, I did try step 1. I will see if change the config file will help.

Last edited 6 years ago by artayo (previous) (diff)

#11 @swissspidy
6 years ago

@artayo Any update on this? Could the error be resolved?

#12 @swissspidy
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing after no feedback for over a year and no reproducible steps.

Note: See TracTickets for help on using tickets.