WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#32650 closed defect (bug) (duplicate)

Ajax plugin updates are very buggy

Reported by: Konnie Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Upgrade/Install Keywords:
Focuses: administration Cc:

Description

Updating plugins via "update now" button is extremely buggy.

For example - plugins may update / fail in a completely random manner. SOmetimes the plugin does not update - you refresh the page and it updates without a problem.
Also if you click 'update now' on several plugins - if one of them fails - the rest will never finish 'updating' - refreshing the page solves this as well.

Anyways, I amtrying to find the code which takes care of this in order to diagnose this further - if someone could please point me towards the right direction - I would really appreciate this!

Change History (2)

#1 @SergeyBiryukov
6 years ago

  • Component changed from Administration to Plugins
  • Focuses administration added

Related: #32086, #32198.

#2 @dd32
6 years ago

  • Component changed from Plugins to Upgrade/Install
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32198.

Definitely a duplicate of the above tickets.

Note: See TracTickets for help on using tickets.