WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32701 closed feature request (duplicate)

Custom Post Type Features

Reported by: freetheweb Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Posts, Post Types Keywords:
Focuses: administration Cc:

Description

The average user has to use a custom post type plugin like Custom Post Types UI to create custom post types. However, this presents a number of issues. First, from what I've experienced anyway, if you disable the plugin after creating the custom post types then your custom post pages stop working. Second, custom post types will not work with the native "category" or "tags" taxonomies without customizing the functions.php file to have them support this.

I think with the widespread adoption and usefulness of custom post types and taxonomies that WordPress should offer some native features to allow for their creation. At the very least, WordPress should automatically allow custom post types to be attached to the native "category" and "tags" taxonomies so that users don't have to rely on researching how to do this with code.

I am not sure whether to file this under a bug or a feature request, but please feel free to move it to whatever you think best suits it.

Change History (3)

#1 @DrewAPicture
5 years ago

  • Type changed from defect (bug) to feature request

#2 @DrewAPicture
5 years ago

  • Component changed from General to Posts, Post Types
  • Focuses administration added

#3 in reply to: ↑ description @DrewAPicture
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Replying to freetheweb:

Second, custom post types will not work with the native "category" or "tags" taxonomies without customizing the functions.php file to have them support this.

I think with the widespread adoption and usefulness of custom post types and taxonomies that WordPress should offer some native features to allow for their creation. At the very least, WordPress should automatically allow custom post types to be attached to the native "category" and "tags" taxonomies so that users don't have to rely on researching how to do this with code.

Closing as a duplicate of #19471.

See also #12617 for discussion on adding custom post types via the admin UI.

Note: See TracTickets for help on using tickets.