WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#32727 closed defect (bug) (fixed)

Customizer: Accessibility: color contrast ratio is poor

Reported by: designsimply Owned by: SergeyBiryukov
Milestone: 4.3 Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: has-patch commit
Focuses: accessibility Cc:
PR Number:

Description

/hat tip @afercia for the original report at https://github.com/voldemortensen/menu-customizer/issues/98

Spotted some light greys on light backgrounds which are under the minimum contrast ratio, for example #999 on #fff in .theme-location-set or current menu location is #999 on #eee. Some of them come from core CSS files.

Attachments (1)

32727.diff (1.0 KB) - added by celloexpressions 4 years ago.
Fix inadequate text color contrast issues.

Download all attachments as: .zip

Change History (8)

#1 @designsimply
4 years ago

Noting a comment from @celloexpressions on the original issue:

We'll need to alter the design intent of the current colors quite a bit to make them meet the contrast guidelines, and they're almost all core colors.

#2 @designsimply
4 years ago

Screenshot for reference:

https://cloud.githubusercontent.com/assets/1119271/8150775/d7f41a38-12c4-11e5-90cc-3bbdee298909.png
Tested with WordPress 4.3-alpha-32775 and Menu Customizer plugin 0.6 (cef7fbc).

#3 @designsimply
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32679.

@celloexpressions
4 years ago

Fix inadequate text color contrast issues.

#4 @celloexpressions
4 years ago

  • Keywords has-patch added; needs-patch removed
  • Milestone set to 4.3
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version set to trunk

This isn't a duplicate - other ticket is about contrast for boxes (regarding borders, backgrounds, etc.), whereas this is about text colors. 32727.diff should do it with the exception of icons that don't meet contrast guidelines (and can't really without changing the design intent more significantly). Note that these changes reduce the visual hierarchy between different pieces of text, but that there's no way around that here.

This ticket was mentioned in Slack in #design by celloexpressions. View the logs.


4 years ago

#6 @celloexpressions
4 years ago

  • Keywords commit added

Should be ready for commit.

#7 @SergeyBiryukov
4 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reopened to closed

In 32982:

Customizer: Increase color contrast ratio for menu locations text.

props celloexpressions.
fixes #32727.

Note: See TracTickets for help on using tickets.