WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32731 closed enhancement (duplicate)

add_menu_page function param: position should be refactored.

Reported by: basdog22 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Plugins Keywords:
Focuses: ui, administration Cc:

Description

Hi.
The add_menu_page func uses the position param to specify the order the plugin menus will have. If 2 plugins use the same position then they override each other.

eg:

add_menu_page('Plugin', 'Plugin', 'manage_options', 'Plugin-plugin-menu', 'Plugin_plugin_options', 'dashicons-box', 101);

and

add_menu_page('Plugin2', 'Plugin2', 'manage_options', 'Plugin2-plugin-menu', 'Plugin2_plugin_options', 'dashicons-box', 101);

Change History (1)

#1 @DrewAPicture
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @basdog22, welcome to Trac!

Sorry it took so long for somebody to get back to you. I'm going to close this as a duplicate of #15595. Thanks for the report!

Note: See TracTickets for help on using tickets.