WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#32748 closed enhancement (duplicate)

Create new dashicons - Save & Cancel

Reported by: prophecy2040 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Formatting Keywords:
Focuses: ui, administration Cc:

Description

The need has come up a few times for icons for save or cancel. 'Save' could possibly be a floppy disk or something similar and cancel the 'universal no/circle backslash' icon. Using the 'x' or 'circle x' is ok for cancel, but that is so synonymous with 'close' these days that it would be beneficial to have a separate icon for that.

Thanks,
Don


Change History (2)

#1 @melchoyce
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #30902.

Generally, I'd advise sticking with WordPress core standards and using "Save [x]" (save changes, save draft, etc.), without an icon. I'm not sure using a prohibition symbol would better than an X, since in general it means "no, don't do this, don't come here," etc.

#2 @prophecy2040
4 years ago

Normally I would agree, but in cases where you don't want to use a button (save) or space is limited, an icon would be great. And the prohibition symbol, as you stated, means 'no, don't do this' which is the perfect meaning for cancel - "no, I don't want to do that - cancel". "X" already means "Close" in almost every instance. We have a trash can, which could be argued could just be an 'X' as well, but the choice is there for the developer to pick from.

I guess this is more a semantics thing, but it would just be nice to have a few more icons to use for developers to choose from and not be locked into what someone else thinks should be used. I hate having to add extra icon sets or images. Dashicons are already loaded into the admin, so adding more ourselves require programming and icon sets - which is more weight than adding a few more icons to an existing resource.

Thanks for listening,
Don

Note: See TracTickets for help on using tickets.