WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 8 months ago

Last modified 8 months ago

#32759 closed defect (bug) (wontfix)

Permalink routing for same slugs in hierarchical structure wrong

Reported by: maszewo Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Permalinks Keywords:
Focuses: Cc:

Description

Hi there, i have a strange problem with identical page-slugs in a hierarchical page-structure:

i have several events structured with pages. each event has a sub-page /show/
one of these is routing wrong, because:

domain.com/pagename/eventname/show/
routes in frontend to
domain.com/pagename/anothereventname/show/

(there are some more events with the sub-page /show/)

  • there are no other custom post types registered
  • no special redirect plugins
  • permalink-structure is updated several times
  • I've tested it on 2 different apache-webservers with the same result

so i dont have any idea yet what i can do! Any suggestions?

Attachments (1)

32759.tests.patch (3.6 KB) - added by johnbillion 4 years ago.

Download all attachments as: .zip

Change History (6)

#1 @johnbillion
4 years ago

  • Keywords reporter-feedback added

Thanks for the report, maszewo.

I'm unable to reproduce this problem. Are you able to test your site with all your plugins deactivated, and one of the default themes enabled?

#2 @johnbillion
4 years ago

32759.tests.patch implements some unit tests to cover this. Tests are passing.

#3 @johnbillion
4 years ago

In 32918:

Implement canonical and url_to_postid() tests for child pages which share a post name with other child pages.

See #32759

#4 @sebastienserre
8 months ago

  • Keywords close added
  • Resolution set to wontfix
  • Status changed from new to closed

I didn't succeed to reproduce.
Please feel free to re-open if needed

#5 @swissspidy
8 months ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.