WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#32767 closed defect (bug) (fixed)

Menu Customizer: reorder arrows tabindex inconsistencies

Reported by: afercia Owned by: ocean90
Milestone: 4.3 Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: needs-patch
Focuses: accessibility, javascript Cc:

Description

When reordering menu items, the move-up/move-down/nest/un-nest arrows have a tabindex attribute that should be updated accordingly with the item position. Please refer to the screenshot below, looks like something is not working correctly, in this example:

  • the first item arrows should be -1 0 -1 -1
  • the second item arrows should be 0 0 -1 0
  • etc.

https://cldup.com/anNvmRjjR9.png

Attachments (1)

32767.diff (1.4 KB) - added by celloexpressions 6 years ago.

Download all attachments as: .zip

Change History (4)

#1 @celloexpressions
6 years ago

  • Keywords has-patch added; needs-patch removed

The problem is specifically with the move left arrows on top-level items. They were being disabled only by css. 32767.diff should do it.

#2 @ocean90
6 years ago

  • Keywords needs-patch added; has-patch removed

With 32767.diff applied I can't move a menu item via menus-move-left anymore.

Last edited 6 years ago by ocean90 (previous) (diff)

#3 @ocean90
6 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 33077:

Customizer: Fix tabindex of reorder buttons for menu items with depth 1 and 10.

props celloexpressions.
fixes #32767.

Note: See TracTickets for help on using tickets.