WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#32888 closed defect (bug) (duplicate)

I get Notices on site with current beta test site

Reported by: mjunker Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Widgets Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use __construct()

Change History (3)

#1 @sbrajesh
5 years ago

Hi,
PHP4 style constructor has been deprecated and that's why you are seeing this. If you are using a plugin, they need to update their code for this.

Please see the details here.
https://make.wordpress.org/core/2015/07/02/deprecating-php4-style-constructors-in-wordpress-4-3/
Hope that helps.

#2 @jeremyfelt
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

#3 @SergeyBiryukov
5 years ago

  • Component changed from General to Widgets
  • Description modified (diff)
  • Resolution changed from invalid to duplicate

Duplicate of #32872.

Note: See TracTickets for help on using tickets.