WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#32898 closed defect (bug) (duplicate)

Polluted database and Menu Crash

Reported by: davidfhannes Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Database Keywords: close
Focuses: Cc:
PR Number:

Description

I have a Woo Commerce website with very large menu structure for the nav bar. Recently when I tried to add to the menu structure under appearances...Menu and press update the page...the page processes and then crashes and gives me a 404 page cannot be found error even though it is the same page.

My server provider informs me that the postmeta_wp table has 2 million rows.

I went to Woo Commerce…System Status…Tools and cleared the following:

WC Transients
Expired Transients
Customer Sessions

Still not resolved.

I have run 2 optimization plugins to no avail to clean out the 2 million rows.

I have added this line to php.ini, which resolved another menu problem, but it does not resolve this: max_input_vars = 3000

Question: Are there things we can do to the settings under PHP Configuration editor on the server or php.ini to resolve this?

Change History (5)

#1 @DrewAPicture
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14134.

#2 @davidfhannes
4 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hi.

I read through ticket #14134.

This ticket deals with menu truncation. My ticket is not about menu truncation. I have encountered menu truncation and resolved it by adding max_input_vars = 3000 to php.ini.

This is about page updating. The page crashes and provides a 404 error every time I try to save the menu. Upping max_input_vars does not resolve my issue. Meantime I'm being told the 2 million lines in postmeta_wp table is causing my complications but I cannot seem to clean it out to test that lead.

(Also ticket #14134 is a convoluted, bloated monster at this point)

Could you please reopen this ticket so my issue may be reviewed and addressed? Thank you.

#3 @SergeyBiryukov
4 years ago

  • Keywords close added
  • Milestone set to Awaiting Review

Please try the support forums for troubleshooting: https://wordpress.org/support/.

#4 @wonderboymusic
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #14134.

comment:3 suggested the Forums 2 months ago

#5 @celloexpressions
4 years ago

Also, for anyone who stumbles upon these types of scaling issues with menus, I'd suggest trying the customizer version as a workaround. It's designed to handle larger menus much more efficiently.

Note: See TracTickets for help on using tickets.