WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 2 years ago

#32921 closed defect (bug) (duplicate)

WordPress mangles text inside <script> tags in posts even if text-control is set to disable any processing

Reported by: fwieland Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Formatting Keywords: reporter-feedback
Focuses: Cc:

Description

I want to be able to add one-off scripts to my Pages. I am already using Text Control to disable any text processing ('No formatting', 'No character formatting'). This works in that it preserves most of the markup, but it still will convert the ampersand character to an XML entity representation.

And, as you may know, the logical and operator in JS is &&.

I take it that there isn't a way to tell WordPress to "just take this and treat it as correct, don't mangle anything, send it to the client, I know what I'm doing", because clearly I'm doing just that using Text Control?

Change History (3)

#1 @swissspidy
6 years ago

  • Focuses administration removed
  • Keywords reporter-feedback added

Hi there, welcome to Trac!

Thanks for creating a patch. Which WordPress version are you using?

It seems to me that this was fixed in [35709], see #34698.

#2 @iseulde
3 years ago

  • Component changed from Editor to Formatting

#3 @pento
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #34698.

Note: See TracTickets for help on using tickets.