WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 8 days ago

Last modified 8 days ago

#32922 closed enhancement (duplicate)

Dashboard Widget API Widget Sorting

Reported by: atomicjack Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Administration Keywords:
Focuses: administration Cc:

Description

In the Dashboard Widget API, it is stated that sorting of widgets is not currently possible.

Could we please have this ability to sort widgets brought into the API?

This could work by setting an order_id on the widgets, where 1 = top widget, and so on, with the admin theme setting how many is displayed per row.

P.S Apologies if this has already been suggested, I did search but didn't find anything.

Change History (2)

This ticket was mentioned in Slack in #core by peterwilsoncc. View the logs.


8 days ago

#2 @mikeschroder
8 days ago

  • Resolution set to duplicate
  • Status changed from new to closed

Hi, @atomicjack !

Thank you for the report!
I'm so sorry it's taken this long for a response to your ticket.

It was discussed during triage today.

In #42791, context and priority arguments were added, and the docs can be found here.

After discussion, it was decided to close this ticket as a duplicate of that one, since it seems like this might solve the problem.

If not, apologies! Please feel free to comment back if it doesn't solve the issue you are having, and re-open this ticket with a description of the problem you're trying to solve.

Thanks again!

Last edited 8 days ago by mikeschroder (previous) (diff)
Note: See TracTickets for help on using tickets.