WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#32931 closed defect (bug) (fixed)

Toolbar: Toolbar icons are not properly colored in the blue theme

Reported by: ryan Owned by: helen
Milestone: 4.3 Priority: normal
Severity: normal Version: 4.3
Component: Toolbar Keywords: has-patch
Focuses: ui Cc:
PR Number:

Description

With 4.3 beta 2, switch to the blue admin color scheme. The toolbar icons are a different color than usual.

Attachments (3)

toolbar__blue_theme__4.2.2__iphone_6_.png (330.0 KB) - added by ryan 4 years ago.
Toolbar with the blue theme, iPhone 6+
toolbar__blue_theme__4.3_beta_2__iphone_6_.png (329.7 KB) - added by ryan 4 years ago.
Toolbar with the blue theme, 4.3 beta 2, iPhone 6+
32931.diff (1.3 KB) - added by ryelle 4 years ago.

Download all attachments as: .zip

Change History (10)

@ryan
4 years ago

Toolbar with the blue theme, iPhone 6+

@ryan
4 years ago

Toolbar with the blue theme, 4.3 beta 2, iPhone 6+

#1 @ryan
4 years ago

Above are before and after screenshots. I'm not seeing the problem on Macnchrome. I quit and restarted iOS Safari, which sometimes clears cache problems. I haven't yet tried clearing out all browser data. If this isn't just another cache problem, it could be due to some specificity issues after #29906.

Last edited 4 years ago by ryan (previous) (diff)

This ticket was mentioned in Slack in #design by helen. View the logs.


4 years ago

#3 @liljimmi
4 years ago

The problem seems to be no matter which color scheme you use the icons are grey.
"Default" and "Light" use grey icons, but all the others use white (or really light grey).

I am not sure how to troubleshoot this, because I can only reproduce it on a phone and not desktop.

Here is a screenshot of "Ectoplasm" on an iPhone 5s.

https://cldup.com/3JxpoBp2jq.png

Last edited 4 years ago by liljimmi (previous) (diff)

@ryelle
4 years ago

#4 @ryelle
4 years ago

  • Keywords has-patch added

Looks like this was a specificity issue caused by the .mobile class on #wpadminbar. I've added those selectors to the color scheme source files in 32931.diff, which seems to fix it.

#5 @obenland
4 years ago

  • Owner set to helen
  • Status changed from new to assigned

@helen, could you give this a final review?

#6 @helen
4 years ago

Yep, I'm looking. There are also some hover state problems and I'm going to see if maybe said hover state is the reason for the double tap/lost click issue noted in #29906.

#7 @helen
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 33284:

Toolbar: Ensure icons are colored correctly in alternate schemes.

props ryelle.
fixes #32931. see #29906.

Note: See TracTickets for help on using tickets.