WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#33013 closed defect (bug) (invalid)

Customizer Menus: creating new menu with enter, not only by clicking button

Reported by: sippis Owned by: celloexpressions
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: needs-patch reporter-feedback
Focuses: javascript Cc:

Description

Just a small usability note: in customizer menus, "New menu name" input should listen also enter. Now you need to click button below input, and it feels not so intuitive.

Change History (9)

#1 @westonruter
5 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

@afercia: Would you consider this an accessibility bug, something that needs to go into 4.3?

#2 @celloexpressions
5 years ago

This is supposed to happen already - it was working at one point, but it stopped working for some reason. If the code is still there that's trying to make this happen we can probably call it a bug and should fix it, otherwise it's an enhancement for a future release. It's not required functionality but makes the flow much faster when using a keyboard, regardless of accessibility.

#3 @westonruter
5 years ago

  • Focuses javascript added
  • Milestone changed from Future Release to 4.3
  • Owner set to celloexpressions
  • Status changed from new to assigned
  • Type changed from enhancement to defect (bug)

I do see the code in api.Menus.NewMenuControl.prototype._bindHandlers:

name.on( 'keydown', function( event ) {
        if ( 13 === event.which ) { // Enter.
                self.submit();
        }
} );

But it's no longer working.

#4 @afercia
5 years ago

Hm this worked at some point :) before accessibility, it's a usability issue. Inputs are supposed to work like native inputs do, they submit on Enter.

#5 @afercia
5 years ago

Just tested in trunk revision 33323 and couldn't reproduce.

#6 @westonruter
5 years ago

  • Keywords reporter-feedback added

I cannot reproduce this issue anymore either. Hitting Enter is resulting in the menu being created.

@sippis Please share your steps to reproduce this issue. Otherwise, if it is no longer valid, please let us know.

#7 @sippis
5 years ago

Okey, this happens only when Twenty Fifteen theme is active. Changing the theme to any other one, example Twenty Fourteen, helps and me neither cannot reproduce this anymore.

So this should be considered as a bug and/or compatibility issue with Twenty Fifteen only.

#8 @westonruter
5 years ago

@sippis Humm, but my testing was with Twenty Fifteen and I did not notice the issue.

#9 @obenland
5 years ago

  • Milestone 4.3 deleted
  • Resolution set to invalid
  • Status changed from assigned to closed

I can't reproduce it either, closing for now.

@sippis, feel free to reopen with concrete steps to reproduce if it still happens to you with all plugins are deactivated. Any JS errors etc. Thanks!

Note: See TracTickets for help on using tickets.