WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 2 months ago

#33027 closed defect (bug) (invalid)

Global Variable for Browser Detection Issue

Reported by: DavidB722 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: General Keywords:
Focuses: Cc:
PR Number:

Description

The browser detection global variable, $is_IE, returns true on Chrome 43.0.2357.134 (64-bit) (latest) on Mac OS X (10.9.5). This does not reproduce with other Webkit browsers (i.e., Safari, Opera). Neither does the issue reproduce with the $is_winIE variable.

Change History (3)

#1 @johnbillion
4 years ago

  • Keywords reporter-feedback needs-testing added

Thanks for the report, David.

I'm running Chrome 43.0.2357.132 (64-bit) on OS X 10.10.3 and $is_IE returns false as expected.

  • What's the value of the $is_macIE global? If $is_winIE is false, then this must be true.
  • What does your user agent look like? You can get this from http://whatsmyuseragent.com/ if necessary.
  • Are you using a proxy or persistent page caching?
  • Does the issue persist with all your plugins deactivated?
  • Does the issue persist with all your browser extensions deactivated?

My user agent on the above is:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.132 Safari/537.36

#2 @DavidB722
4 years ago

  • Keywords reporter-feedback needs-testing removed

Hi, John

Apologies for the late response. My user agent:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.134 Safari/537.36

I was able to reproduce the issue tonight in a testing environment in Firefox, as well ($is_IE returned true in FireFox), but was unable to reproduce it in Chrome. All browser extensions de-activated in FF at the time. When testing after de-activation of plugins, the issue fails to reproduce. This site is using a caching plugin...my guess is that something is conflicting there. It's probably safe to say this isn't an issue in core, and we should probably close this ticket as not a bug.

#3 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Could not reproduce either, sounds like a caching issue.

Note: See TracTickets for help on using tickets.